Página 1 de 1

erro configuração na publicação

Enviado: 23 Jun 2012, 17:27
por Heric Souza
Olá,

após concluir uma aplicação simples, executando corretamente via navegador, via VS e publicação local, sempre com a configuração do banco na web.

Seguindo a dica do amigo Adriano, estou com o seguinte erro na publicação no locaweb (com destaque em vermelho na linha 48):

"...
Server Error in '/' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.

Source Error:


Line 46: <!--End Locales-->
Line 47: <system.web>
Line 48: <sessionState timeout="20" />
Line 49: <httpRuntime requestValidationMode="3.5" />
Line 50: <authentication mode="Forms">

Source File: E:\Home\digsistemas\Web\interno\web.config Line: 48


Show Additional Configuration Errors:
Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272
..."

Agradeço alguma sugestão.

Re: erro configuração na publicação

Enviado: 24 Jun 2012, 23:25
por adrianodrv
Me parece um problema simples, vc deve ter compilado e gerado a aplicação utilizando o .Net 4.0 e esta tentando coloca em abiente .Net 3.5, ou vice-versa. De uma olhada no teu serviço de hospedagem, se for Windows 2003 Server, vc não terá suporte para o .NET 4.0 e tera que mudar para o WIN 2008 e utiliza-lo sem custo nenhum.

Abraços,

Adriano Vieira.

Re: erro configuração na publicação

Enviado: 25 Jun 2012, 08:36
por Heric Souza
Adriano,

estou usando o .NET 4 mesmo, mas o servidor já é o 2008.

Postei no HD da LocaWeb e eles ajustaram a configuração, já está logando a aplicação, mas agora apresenta erro na janela de dados...

Mas a resposta do suporte foi rápida e eficiente, postarei este novo erro.

Obrigado!

Re: erro configuração na publicação

Enviado: 25 Jun 2012, 11:05
por adrianodrv
OK.
Então agora vc entra (loga) na aplicação mais da erro quando vc abre uma pagina de dados é isso ? Qualquer página de dados ?


Adriano Vieira.

Re: erro configuração na publicação

Enviado: 25 Jun 2012, 13:09
por Heric Souza
Adriano,

sim, mas conforme falei no início, a aplicação é bem básica e tem apenas uma tabela clientes, com duas páginas de dados da mesma tabela e, em ambas aparece o erro.

Já as páginas de manutenção de senha e construção de consultas funcionam.

Re: erro configuração na publicação

Enviado: 25 Jun 2012, 19:03
por adrianodrv
Mas no seu equipamento funciona normalmente a aplicação ? Estranho isso.....

Abraços,

Adriano Vieira.

Re: erro configuração na publicação

Enviado: 27 Jun 2012, 08:22
por Heric Souza
Olá a todos,

prosseguindo no atendimento, o suporte da locaweb perguntou e não sei responder:

"... > Nível de Trust que a aplicação precisa (medium ou Full Trust) ..."

Alguém saberia me dizer?

Re: erro configuração na publicação

Enviado: 27 Jun 2012, 10:54
por adrianodrv
Trata-se da segurança do ambiente do servidor para o ASP.NET, não precisei fazer nada disso ai, mas creio que deva deixar em Full Trust para evitar problemas futuros.

Abraços,

Adriano Vieira.

erro configuração na publicação - encerrado

Enviado: 27 Jun 2012, 17:34
por Heric Souza
Amigo Adriano, boa tarde!

Seguindo orientação do Almeida Neto, apaguei todo o conteúdo do ftp, regerei todo o projeto e novamente fiz o upload, funcionando!!!

Muito Obrigado!